HELP!! Calcium or manganese?

Discussion in 'Marijuana Plant Problems' started by Valley_559, Mar 8, 2018.

  1.  
    Valley_559

    Valley_559 Member

    Seem to be having a calcium or manganese deficiency in a few of my clones, strains are royal highness, gorilla glue#4 and blackberry fire. Also some of my plants seem a lil too light green almost yellowish, got these clones Saturday out of harborside in cubes with hardly any roots now the roots are healthy and strong, white, they are in fox farm happy frog. Tap water with a PH of 6.0-6.5 a ppm of 213. Any HELP would be GREATLY appreciated. Also new to this site.
     

    Attached Files:

  2.  
    Tim1987

    Tim1987 Well-Known Member

    Hey mate.
    Sorry.
    Ph / ec BIG TIME
    Good luck
    Tim
     
  3.  
    Valley_559

    Valley_559 Member

    Any help on how to fix? Thanks man!
     
  4.  
    Tim1987

    Tim1987 Well-Known Member

    What medium are you in?
    How do you test ph/ec's?
     
  5.  
    Valley_559

    Valley_559 Member

    Fox farm happy frog soil, I test ph two ways as you'll see in the below pictures and the ppm(ec) with the digital tester
     

    Attached Files:

  6.  
    Valley_559

    Valley_559 Member

    Pics in other reply, still learning how to use this site
     
  7.  
    Tim1987

    Tim1987 Well-Known Member

    You need to get your ph determined FIRST.
    If it is a solo cup/small pot you can check the runoff. Ph test your water FIRST. See if the the runoff is different.
     
  8.  
    Valley_559

    Valley_559 Member

    What should runoff PH be?
     
  9.  
    Tim1987

    Tim1987 Well-Known Member

    You need to check the difference to what you are putting in.
    If you run off is higher. You need to go lower.
    If its lower. Go higher.
    Tim
     

Share This Page