Supersoil - Too Wet & Smells Bad

Discussion in 'Subcool's Old School Organics' started by Comacus, Jun 29, 2013.


    Comacus Member

    Well I had about 5 gallons of Supersoil left in a container. It was dry so I rewetted it to get the soil life going again. I think I got it too wet, and now it has a bad smell. It is not a sweet organic smell but more of a sewer smell. [HR][/HR] I am concerned I got the bad anaerobic microbes going instead of the good ones. If I let the soil dry to an appropriate moisture level, will the good microbes start up again to where this supersoil will be OK, or should I trash it?

    GreenSanta Well-Known Member

    personally I have never had any issues ... But I usually transplant in plain promix and the root dont get to the supersoil right away ... it gives it time to ''fix itself'' .. .especially in smart pot

    Kevdogg5555 Well-Known Member

    ive had this happen. I poured all the soil of a tarp to let it dry out completely, then i re wet it with compost tea, but i made sure not to over water that time GOOD LUCK
    geekmike likes this.

    geekmike Well-Known Member

    lay it out on a tarp or plastic bag for a few days, turn it over, then back in the bucket

    Comacus Member

    Thank you. The heat wave here in CA did a nice job of drying it out this weekend. It is back in the bucket at a more normal moisture level.

    ReefBongwell Well-Known Member

    Next time water 20% by volume (5gal soil = water 1 gallon water) and fuggedabout it. Agree on laying it out to dry then rewetting.

Share This Page