Need help ID and treatment

Discussion in 'Bugs' started by jrainman, Mar 26, 2013.

  1.  
    jrainman

    jrainman Active Member

    Dam, I was just here in this section the other day trying to learn about bug problems,being a newbi, anyhow last nite did a little lite LST to one of my two plants, so really went through both plants really good , and yea saw a little fucker fly in the closet (think it was a nat) could not find it thought I ran it off, but this morning this is what I found ,2 lower leafs def got eaten I think, So take a look and tell me what you think and yes what should I do to treat this. cant believe this damage was done inside of like 7 hours tops. 004.jpg 005.jpg 009.jpg
  2.  
    Zoltan44x

    Zoltan44x Active Member

    Im having the same problems and first thought it could be a nutrient def. Then looked for bugs, but I could not find anything.
    Suspected that they can be broad mites, since the symptoms was similar to described in Icmag where people thought it was TMV at the beginning and then turned out broad (cylamen) mites. Including Your symtptoms ,I also have twisting in new sprouts.
    Link here for the thread in icmag.

    I tried avid but it didnt solved my problem.
    Lower leafs in shady areas are affected in my case. And also new sprouts. Someting is eating them and I cant frickin find the monster.
    My lights will be on in an hour, and Ill post pics.
  3.  
    Zoltan44x

    Zoltan44x Active Member

    Here are the pics. Difrerents plants, similar problems and the last picture is showing overfeeding signs too. However, I cant stop it.
    Flushing mildly, giving calmag, spraying with avid, nothing works in my case. Other than this, my plants are fine. No stunting , and keep growing.

    Attached Files:

    • p1.jpg
      p1.jpg
      File size:
      49.6 KB
      Views:
      15
    • p2.jpg
      p2.jpg
      File size:
      69.3 KB
      Views:
      18
    • p3.jpg
      p3.jpg
      File size:
      64.6 KB
      Views:
      14
    • p4.jpg
      p4.jpg
      File size:
      46.1 KB
      Views:
      16
  4.  
    renegade23

    renegade23 Member

    are you foliar feeding?
  5.  
    jrainman

    jrainman Active Member

    Thanks for the help, this is something I want to treat ASAP, I see. yea def same eating activity, going on I found two more leafs tonite ,I noticed they are not touching the big fan leafs, like in your pics , and no def no twisting on new growth, my fan was on when I took those pictures, and MH everythigng you should not due when taken pictures,
  6.  
    jrainman

    jrainman Active Member

    No not foliar feeding ,
  7.  
    Zoltan44x

    Zoltan44x Active Member

    hey jrainman,

    I sorted this out. It turned out that I burned them with too much flowering additives, and Snow Storm Ultra was responsible.
    So mine was not a bug problem but overfeeding. I hope Your ladies are fine too.

    Happy growing
  8.  
    Dameon

    Dameon Active Member

Share This Page