In need of advice from fellow hydro growers

Discussion in 'Hydroponics / Aeroponics' started by Jumpin, Jan 30, 2013.

  1.  
    Jumpin

    Jumpin Active Member

    I am about to pull out my teeth if I can not figure this out. I have a drain and fill setup, 150watt hps, 5.8-5.9ph level, using distilled water with advanced nutri, feeding 3X while lights on. She is also in flowering for 5 wks so I do not know what I can spray. She looked beautiful until about a week ago. The tips started turning brown on the upper fan leaves. Then the lower leaves started to get brown tips and curl under as well. I did adjust the feeding because I thought I was over fertilizing. Now brown spots are appearing on some of the leaves. I also just noticed that the roots that are towards the outside of the res have white fungus. I do not know what to do for this either. Its not a lot but I know that it can spread quickly so I need advice. I attached a few pictures. Please help, I usually get good advice from forums here and I hope this time is the same I do not know what else to do.
  2.  
    Land

    Land Member

    I would stop using distilled water to start off with. I've had poor success when I used distilled water and heard the same from other people too. Can you use your tap water or is it to hard?
  3.  
    Jumpin

    Jumpin Active Member

    tap water is too hard and has a high rust content, i wont even drink it. Can I use drinking water bottled?
  4.  
    nameno

    nameno Active Member

    Where is your tap water come from?I have bad water but I let it set out for a few days & it's been working. I use GH line of nutes.They have a micro for the hard water I haven't had to try that yet. Looking at those roots you got more problems what is your water temp? Looks like you got the funk coming on.I'm new some might be right some might be wrong.Wait on someone with more experience than I.Good Growing to ya!Peace
  5.  
    hammer21

    hammer21 Active Member

    Maybe cal mag deficiency. Get a ro unit or use bottled drinking water. Any light getting into res? Also wondering what res temp is try to get it between 66-68 degrees
  6.  
    noxiously

    noxiously Active Member

    High water temps are the devil. If you are having root problems and you are running hydro, then most often the water is probably too warm, as well as maybe not enough oxygen being pumped into your res which will result in stagnate water and that will mess those roots up quick and the rest of the plant will follow.

Share This Page