3 weeks into flower dieing yellow leaves + Thrips

Discussion in 'Marijuana Plant Problems' started by Zootime, Nov 23, 2010.

  1.  
    Zootime

    Zootime Well-Known Member

    I'm around 3 weeks into flower with my auto's but they still have a while to go, the problem is all the fan leaves seem to be going yellow, crisping and falling off.

    Here is a pic i could get:

    View attachment 1285758 View attachment 1285759

    Hopefully you can tell whats wrong by this, sorry about the quality.

    Grow info:
    Ferts - Organic Biobizz grow/Biobizz bloom/Biobizz fish mix/molasses/
    water - distiled water
    soil - biobizz all mix
    PH - 6.5/7.0
    Lights - 250w CFL 2700k + 125W wat CFL 2700K
    Light Schedule - 20/4
    temps - 70
    RH - 42%

    Note: i also have a new thripe or mite infestation, not sure which yet because they are so small, but there little brown specs that crawl around on the fan leaves.

    Any advice would be greatly appreciated.
  2.  
    Zootime

    Zootime Well-Known Member

    I don't know whether i need to give my plants more nutes or need to flush, please someone help me before i kill my babys.
  3.  
    Nice Ol Bud

    Nice Ol Bud Well-Known Member

    Flush, You might have to do early harvest :(
  4.  
    howhighru

    howhighru Well-Known Member

    I have an overfertilization deal going on with my girl right now, i would def flush n see if that helps. I am also using Biobizz, but i added that with FF BB and I shouldnt have due to the nutes already in the soil. My dumb ass wasnt thinkin about that when I fed her..

    FLUSH! It can only help..

    Dont add NO more nutrients before you do..
  5.  
    Zootime

    Zootime Well-Known Member

    Ah that would suck, the buds are still premature, the hairs are still white with one or 2 being brown, like i said im only 3 weeks into budding.

    Yeah, i forgot to mention im also using biobizz all mix soil! Damn this biobizz stuff must be strong then... but how do you know its not a deficiency? Are you sure its overfertilization for my plants?

    If you look at the second picture their is a leaf on the plant to the left with a green line going through the middle and the rest of the leaf yellow (on my other plant) ...?

Share This Page