Seedling fastberry auto

Discussion in 'Auto-Flowering Strains' started by zackzp23, Jan 22, 2018.

  1.  
    zackzp23

    zackzp23 New Member

    How is my fastberry auto seedling looking? This is my first grow, I STARTED germination on 1/13, sprouted on 1/18. She is under a 300w led
     

    Attached Files:

  2.  
    DankFrank888

    DankFrank888 New Member

    I just ordered some of these seeds! Gl man keep posting updates.
     
  3.  
    zackzp23

    zackzp23 New Member

    Day 15, not sure what the brown spots on the leaves are about
     

    Attached Files:

  4.  
    Dendrophilly

    Dendrophilly Well-Known Member

    What's in your soil? peatmoss and perlite?

    The struggle is real.
     
  5.  
    zackzp23

    zackzp23 New Member

    Actually it is not pest Moss, the top 1in layer of the pot is there to help the soil hold moisture considering smart pots cause the soil to dry much quicker :)
     
  6.  
    zackzp23

    zackzp23 New Member

    Day 19, spots are still popping up on new growth, fed nutes for the first time 3 days ago. Doesn’t seem to have fixed the problem. Still growing at a good rate though
     

    Attached Files:

  7.  
    upnsmoke13

    upnsmoke13 Well-Known Member

    What nutes you using? May need some cal-mag. Take a pic under normal lighting, easier to see. Go slow on nutes, usually autos are light feeders.
     
  8.  
    zackzp23

    zackzp23 New Member

     
  9.  
    zackzp23

    zackzp23 New Member

    Fed cal mag yesterday, hopefully the problem has been fixed
     

    Attached Files:

Share This Page