Help my plants are dying...

Discussion in 'Marijuana Plant Problems' started by Justin Freidman, Mar 5, 2018.

  1.  
    Justin Freidman

    Justin Freidman Active Member

    Hey Guys,

    Can anyone advise what I'm doing wrong? Or what to do? I thought I had every dialed in. I've just been away for a week and when I got back the plants don't look very healthy at all.

    Should I flush them for the next 24 hours with RO pH balanced water, then try a weaker solution at 0.3EC?

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Thanks
     
  2.  
    Tiffj

    Tiffj Well-Known Member

    It seems to be getting nute poisoning dude!!
     
    Stink Bug, Orlando737 and Cold$moke like this.
  3.  
    kingtitan

    kingtitan Well-Known Member

    Looks like Calcium deficiency. You got brown spots and leaves that are contorting
     
    Orlando737 likes this.
  4.  
    Cold$moke

    Cold$moke Well-Known Member

    I think your over nuting as well
     
    Stink Bug and Tiffj like this.
  5.  
    Cold$moke

    Cold$moke Well-Known Member

    Cut the mix in half then ph @6 for 2 days see if she perks up :)

    Can you set your meter to ppm what im used to.

    Are your roots in water?
     
  6.  
    Justin Freidman

    Justin Freidman Active Member

    Hey Guys, thanks for taking the time to reply.

    I flushed them with pH balanced (6.0) RO water, then made up a new batch of nutrients.

    I took the EC from 0 to 0.2 with calmag, then up to 0.4 with Hesi grow. We'll see if this works.

    I'm sure I added calmag on the last mix (might have been stoned and forgot)
     
    Cold$moke likes this.
  7.  
    Cold$moke

    Cold$moke Well-Known Member

    Just give them 2 days to notice a change :)

    Most newer growers will try somthing and if they dont see any results they freak out after just a few hours lol.

    I usually give my girls up to 3 days to notice a change ....

    Good luck :)
     
    Beachwalker likes this.
  8.  
    neved

    neved Well-Known Member

    Hi , over nut 100% , and y have root prb 4 sure , hydro or soil or dwc !?
     
  9.  
    Justin Freidman

    Justin Freidman Active Member

    I think it must have been bad nutes.... these Hesi ones are rocking, check out this recovery!


    [​IMG]
     
  10.  
    Justin Freidman

    Justin Freidman Active Member

    P.S. I'm running C02 at 1000, upped temp to 28(c) and RH at 65%
     
  11.  
    Cold$moke

    Cold$moke Well-Known Member

    Cough cough bad nutes lol

    Looks better now :)
     

Share This Page