ball valve failure

Discussion in 'Concentrates and Extracts' started by cookie master, Feb 2, 2018.

  1.  
    cookie master

    cookie master Well-Known Member

    Im so confused, I have 2 swagelok valveswhich both failed the first day. One of them I see a seal slipping. On both when I look into the 1/2 inch hole there doesnt appear to be a ball. Its a straight up and down CYLINDER and not a ball/ and it doesnt move with the valve handle??? I have another of the same valve and that one is clearly a ball and appears to work??? part # ss-45 f8
     
  2.  
    Tom Tucker 313

    Tom Tucker 313 Active Member

    Just replace them. Gaskets and all
     
  3.  
    Fadedawg

    Fadedawg Well-Known Member

    Back to Swagelok!!!!!!!!
     
    R&RHashman likes this.
  4.  
    Tom Tucker 313

    Tom Tucker 313 Active Member

    Sometimes they deliver broken stuff
     
    R&RHashman likes this.
  5.  
    R&RHashman

    R&RHashman Well-Known Member

    one of our managers at work(the guy that buys the parts) loves them but hates them for this exact reason. seems funny it only happens if its a mail order if he goes to a dealer in town never has a problem. not saying it is like this every time but seems like when it does happen its a order that came in the mail
     
  6.  
    cookie master

    cookie master Well-Known Member

    I Got a refund but I took it apart to see. It has 4 seals inside and they were in the wrong orientation. I may be able to save them.
     
    Fadedawg likes this.

Share This Page