Plantmax bulb blew after a couple weeks ???

Discussion in 'General Marijuana Growing' started by Gsxkid, Mar 26, 2013.

  1.  
    Gsxkid

    Gsxkid Member

    What would cause this to happen its only a couple weeks old?
  2.  
    Nullis

    Nullis Moderator

    The lamp wattage matches the ballast wattage, correct?

    PlantMax is a cheap brand. Bring it back to where you bought it from and exchange it.
  3.  
    Gsxkid

    Gsxkid Member

    Bought it as a kit with ballast and hood. It's just striking me right now is a fan required to be run on a hood or do people just do it to cool there room? My room temps stay fine without one but is it needed to cool the lamp?
  4.  
    Nullis

    Nullis Moderator

    What is the wattage though? What brand ballast is it exactly, anyways? You are sure the wattage of the lamp is correct and the bulb is the correct type? (HPS, MH...many run both)

    People have air-cooled hoods and duct fans for cooling higher wattage bulbs; it isn't required to have it air cooled as long as the temperature in the canopy isn't too hot. You should at least have a regular fan circulating air in the room.
  5.  
    Gsxkid

    Gsxkid Member

    There is a Fan circulating in the room. The room stays in the high 70s. The bulb is a 1000 watt the ballast is switchable from MH/ HPS. It's an enclosed hood with 8 inch duct take offs on both sides. I coudnt say what the temps are within the hood. It's a lummi hood something like that. I forget what the ballast is. The ballast where the switch is says right on it 1000w HPS/ 1000w MH

Share This Page